● Forum news V2.1

Fri Apr 01, 2022 3:26 pm
Spammer
105 Posts
casterdon
Currently Offline
Offline
  
Doesn't like playing games!
Reputation: 756.1
Hi coRpSE, have a problem with v2.1 forum news, here are a few pics

These are the settings
Expand

No social media links
Expand

Expand

The page numbers  i have set to 3 per page,  when you select next for the fourth news item i will not show up it is just blank.

Expand

I have also set it in the forum admin (at a glance options).
Fri Apr 01, 2022 6:20 pm
Clan Leader
Top Dog
Nuke Dev / Coder
2815 Posts
coRpSE
In-Game
SCUM

Most Played:
This week: 36.0hrs.
Total Played: 517hrs.


  
Reputation: 7011.2
votes: 6
Okay, the social icons, I am not sure on that. I can get them to work on both my site and on my local.

As for page two showing nothing, below is a temp fix until I can come up with more of a permanent fix.

Open: public_html/modules/Forum_News/index.php
Find:

PHP:  [ Select all ]

$perpage = (defined('HOME_FILE')) ? $perpage '10'

 
Place // infront of it, so it looks like this:

PHP:  [ Select all ]

//$perpage = (defined('HOME_FILE')) ? $perpage : '10'; 

 
Save
Fri Apr 01, 2022 6:45 pm
Original Poster
Spammer
105 Posts
casterdon
Currently Offline
Offline
  
Doesn't like playing games!
Reputation: 756.1
Hi m8, yep social icons works ok on local, but not on the web. the fix above worked on both, web and local.

Thanks coRpSE


 
Fri Apr 01, 2022 7:12 pm
Clan Leader
Top Dog
Nuke Dev / Coder
2815 Posts
coRpSE
In-Game
SCUM

Most Played:
This week: 36.0hrs.
Total Played: 517hrs.


  
Reputation: 7011.2
votes: 6
No problem. Are there any errors showing up in any of your logs for the forums_news?


 
Sat Apr 02, 2022 6:32 am
Original Poster
Spammer
105 Posts
casterdon
Currently Offline
Offline
  
Doesn't like playing games!
Reputation: 756.1
No errors showing in the logs m8, strange again one works in local but not on the web, could it be anything to do with
Please login to see this link
Get registered or Log in
although everything else is fine.


 
Sat Apr 02, 2022 1:40 pm
Clan Leader
Top Dog
Nuke Dev / Coder
2815 Posts
coRpSE
In-Game
SCUM

Most Played:
This week: 36.0hrs.
Total Played: 517hrs.


  
Reputation: 7011.2
votes: 6
I don't think so, since my site here is https. Is it publicly visible so I can take a look at it?


 
Sat Apr 02, 2022 3:30 pm
Original Poster
Spammer
105 Posts
casterdon
Currently Offline
Offline
  
Doesn't like playing games!
Reputation: 756.1
well for some reason it will not show to all visitors i have tried to change it but still want show unless you are login, but yes take a look anyway m8, tell me what you think, having a problem with the steam addon, again prefect on the local but not on the web, just about to have another go see if i can get it to work.  hrm


 
Sat Apr 02, 2022 7:18 pm
Clan Leader
Top Dog
Nuke Dev / Coder
2815 Posts
coRpSE
In-Game
SCUM

Most Played:
This week: 36.0hrs.
Total Played: 517hrs.


  
Reputation: 7011.2
votes: 6
You went to ACP->Modules, then scrolled down to "Forum News", and set that as Active, and also set it as Home, and you have the View set to All Visitors?

If you don't have all that, then it won't show as intended.
Should look like this:
Expand


 
Sun Apr 03, 2022 12:55 pm
Original Poster
Spammer
105 Posts
casterdon
Currently Offline
Offline
  
Doesn't like playing games!
Reputation: 756.1
Hi coRpSE, that's how it is setup m8, I have a problem with logging in on the front end, it will log me in then log me out, admin backend no problem.
This is what I get

Cookie functions seem to be disabled.
Please change your browser settings!

My browser is enabled

In preferences
Site Url =
Please login to see this link
Get registered or Log in


In general board settings forum end
cod-sniper-clan.co.uk

cookie settings
Cookie domain = .cod-sniper-clan.co.uk
Cookie name = cod-sniper-clan
Cookie path /

Cookie secure = enabled  :?

I activated your account as well the answer was tree I changed it to trees  eek


 
Forums ©