Forum News module 3.1 issue [SOLVED]

118

Fri Oct 29, 2021 7:02 pm
NOOB!!!
34 Posts
i have this error making a new post, first time ive tried so am not sure if its been a recent edit. maybe forum news v3 caused it

Code: [ Select all ]

Error in posting

DEBUG MODE

SQL Error : 1366 Incorrect integer value: '' for column 'enable_bbcode' at row 1

INSERT INTO nuke_bbposts (topic_id, forum_id, poster_id, post_username, post_time, poster_ip, enable_bbcode, enable_html, enable_smilies, enable_sig, post_icon) VALUES ('1917', '1', 2, 'e2c77c599b', '1635559125', '519ce867', '', '1', '1', '1', 0)

Line : 364
File : functions_post.php


Code: [ Select all ]

---------[SQL Error]------------------------------------------------------------------------------------------------------------
- [30 Oct 2021 - 01:58:45] -
User: REMOVED
IP: REMOVED
URL: /modules.php?name=Forums&file=posting

File: /var/www/html/REMOVED.com/public_html/includes/functions_post.php
Line: 362
Message: Incorrect integer value: '' for column 'enable_bbcode' at row 1
Code: 1366
Query: INSERT INTO nuke_bbposts (topic_id, forum_id, poster_id, post_username, post_time, poster_ip, enable_bbcode, enable_html, enable_smilies, enable_sig, post_icon) VALUES ('1917', '1', 2, 'e2c77c599b', '1635559125', '519ce867', '', '1', '1', '1', 0)
---------------------------------------------------------------------------------------------------------------------------------
 
---------[Message die() called multiple times]------------------------------------------------------------------------------------------------------------
- [30 Oct 2021 - 01:58:45] -
User: REMOVED
IP: REMOVED
URL: /modules.php?name=Forums&file=posting

Error Code: 202
Error Message : Error in posting
Error Title:
Error Line: 364
Error File: /var/www/URLREMOVED.com/public_html/includes/functions_post.php
Error SQL: INSERT INTO nuke_bbposts (topic_id, forum_id, poster_id, post_username, post_time, poster_ip, enable_bbcode, enable_html, enable_smilies, enable_sig, post_icon) VALUES ('1917', '1', 2, 'e2c77c599b', '1635559125', '519ce867', '', '1', '1', '1', 0)
Fri Oct 29, 2021 8:40 pm
Clan Leader
Top Dog
2689 Posts
coRpSE
Online
Most Played:
This week: 69.4hrs.
Total Played: 69hrs.


  
Must be a looser...
I split, the topic for your post has nothing to do with that update and really should have been a new topic.
The error is within your edits. I just installed this again on my second local and works great. Be cautious on editing the posting.php file. There is an edit that you need to do twice, and it tells you to do both instances of it.
Fri Oct 29, 2021 9:23 pm
Original Poster
NOOB!!!
34 Posts
not sure what was the cause, i couldnt reply or make a new thread. i tried 2 old saved DBs, no difference. the only thing that made a difference is a public hmtl roll back(tried3 versions). i can now reply but still cant post. before i start building everything back up again, i really need to find a fix so i can make a new thread. i am thinking it might be related to the oldposts/users moved onto new version of evo, but i did post one new thread days ago. if yous can help, free beer and hookers for yous :D

Code: [ Select all ]


Error in posting

DEBUG MODE

SQL Error : 1366 Incorrect integer value: '' for column 'forum_news' at row 1

INSERT INTO nuke_bbtopics (topic_title, topic_poster, topic_time, forum_id, topic_status, topic_type, forum_news, topic_icon, topic_vote) VALUES ('test', 2, '1635567069', '1', 0, '0', '', 0, '0')

Line : 331
File : functions_post.php



Code: [ Select all ]

--------[SQL Error]------------------------------------------------------------------------------------------------------------
- [30 Oct 2021 - 04:11:09] -
User: REMOVED
IP: REMOVED
URL: /modules.php?name=Forums&file=posting

File: /var/www/html/URLREMOVED.com/public_html/includes/functions_post.php
Line: 329
Message: Incorrect integer value: '' for column 'forum_news' at row 1
Code: 1366
Query: INSERT INTO nuke_bbtopics (topic_title, topic_poster, topic_time, forum_id, topic_status, topic_type, forum_news, topic_icon, topic_vote) VALUES ('test', 2, '1635567069', '1', 0, '0', '', 0, '0')
---------------------------------------------------------------------------------------------------------------------------------

 

Code: [ Select all ]

---------[Message die() called multiple times]------------------------------------------------------------------------------------------------------------
- [30 Oct 2021 - 04:11:09] -
User: REMOVDED
IP: REMOVDED
URL: /modules.php?name=Forums&file=posting

Error Code: 202
Error Message : Error in posting
Error Title:
Error Line: 331
Error File: /var/www/html/URLREMOVED.com/public_html/includes/functions_post.php
Error SQL: INSERT INTO nuke_bbtopics (topic_title, topic_poster, topic_time, forum_id, topic_status, topic_type, forum_news, topic_icon, topic_vote) VALUES ('test', 2, '1635567069', '1', 0, '0', '', 0, '0')


 
Fri Oct 29, 2021 9:26 pm
Clan Leader
Top Dog
2689 Posts
coRpSE
Online
Most Played:
This week: 69.4hrs.
Total Played: 69hrs.


  
Must be a looser...
Well, send me FTP and temp admin, and I will see what I can do. I don't need database info as long as you already have the SQL ran.


 
Fri Oct 29, 2021 9:27 pm
Original Poster
NOOB!!!
34 Posts
i am seeing forum news mentioned, that is a roll back. that must be related to the forum news v3 i tried to install that turned out to be the wrong version


 
Fri Oct 29, 2021 9:38 pm
Original Poster
NOOB!!!
34 Posts
ill need to create a user via putty etc mate. going to catch some zzzs the now but ill get you those details. cheers


 
Sat Oct 30, 2021 8:03 pm
Clan Leader
Top Dog
2689 Posts
coRpSE
Online
Most Played:
This week: 69.4hrs.
Total Played: 69hrs.


  
Must be a looser...
Okay, site is fixed.
I marked post as solved.


 
Sun Oct 31, 2021 5:31 am
Original Poster
NOOB!!!
34 Posts
thanks again mate


 
Forums ©