How to disable CPU Core Parking For Multi-Core Processors

2

Fri Jul 24, 2015 5:22 pm
Clan Leader
Top Dog
2630 Posts
coRpSE
In-Game
State of Decay 2

Most Played:
This week: 90.4hrs.
Total Played: 135hrs.
  


For those of you who are using laptops with Windows 7 or Vista installed, you may be disappointed to find out the dual, quad or octal core processor you invested in isn't actually using all of the cores. That's right... out of the box these operating systems do not fully enable the distribution of processes over the cores for certain system configurations. For the most part, these configurations are limited to laptops.

The reason for disabling multiple cores really comes down to energy consumption. The default power profiles set forth by Microsoft opt for an energy savings based configuration, even when the power settings are set to full performance. Personally, I find it rather obnoxious, as once I disabled core parking, I saw a significant increase in all of my processor intensive tasks.

How To Disable CPU Core Parking For Dual And Quad Processors:

  1. Copy the following registry key entry between the brackets, (Only the yellow text), [ 0cc5b647-c1df-4637-891a-dec35c318583 ].

  2. Select your start button.

  3. In the search box, type 'regedit' and press enter.

  4. Once your registry editor is open, select 'Edit' and 'Find...'.

  5. Paste the above registry key in the box and select 'Find'.

  6. Once it has located it, look for the keys on the right hand side labeled MinValue and MaxValue.

  7. Double click on each value and make sure they are both set to '0'.

  8. Select 'Edit' and 'Find Next...'.

  9. Continue to replace MinValue and MaxValue for each entry until you have replaced them all.

  10. Close the registry editor and shut down your computer.

  11. Power the computer back up.

  12. Core Parking should now be disabled.


To check whether or not your cores are parked simply press ctrl + alt + del and open the task manager. You can then select the 'Performance' tab and open the 'Resource Monitor...'. Within the resource monitor, select the 'CPU' tab and look at the graphs on the right hand side. None of the CPUs should say, in text, that they are parked. If they do not, then your processor cores are not parked.


Expand
Tue Jul 28, 2015 12:27 pm
NOOB!!!
36 Posts
^7[^2I^7S^1S^...
Online
Most Played:
This week: 52.8hrs.
Total Played: 1,047hrs.
  
Must be a looser...
Thanks for this coRpSE, that worked on my pc, now none are parked.  big grin
Tue Jul 28, 2015 2:09 pm
Original Poster
Clan Leader
Top Dog
2630 Posts
coRpSE
In-Game
State of Decay 2

Most Played:
This week: 90.4hrs.
Total Played: 135hrs.
  
I just found that for a clan mate and figured others may benefit from it.


 
Thu Jul 30, 2015 8:17 am
Clan Leader
No Life!!!
343 Posts
I followed the instructions and all my min and max values are set to "0" and it still parks half my Cores....


Expand
Thu Jul 30, 2015 11:00 am
Clan Leader
No Life!!!
343 Posts
Got it to work. I had to disable an optimizing program that kept 4 of my processors "Parked"
Thanks!!!!


 
Forums ©