Goto page Previous  1, 2

Steam Profile Mod v1.0.1 :: [ Released ]

2

Sat Sep 19, 2020 5:58 am
Nuke Dev / Coder
63 Posts
Lonestar
Currently Offline
Offline
  
Doesn't like playing games!
Hmm, Strange I thought with the file been empty it just want not receiving the data from the XML file. You have probably already tried this? But try making a new API key and double check the 64bit id is correct and has not got any spaces before or after the ID.

I have had a couple of people with Steam problem, turns out to be their API key. Let us know.


Expand
Sat Sep 19, 2020 10:08 am
Original Poster
Clan Leader
Top Dog
2614 Posts
coRpSE
Currently Offline
Offline

Most Played:
This week: 46.0hrs.
Total Played: 237hrs.
  
Don't get much, huh?
Is this on a localhost? Meaning, are you hosting this on your computer using something like Xamp or Wamp?
If so, are you seeing the "Live Feed from Evolution Xtreme" in the ACP. If not, then ignore what I just asked.

Also, verify what lonestar mentions above.


Expand
Sat Sep 19, 2020 5:04 pm
NOOB!!!
36 Posts
^7[^2I^7S^1S^...
Online
Most Played:
This week: 44.6hrs.
Total Played: 879hrs.
  
Don't get much, huh?
Hi coRpSE, well did a complete install of E then F and re-installed it again, but still the same thing, but dont  let it bother you m8 i will setup a proper website on the net, by the way i have been using wamp64, as i say dont let it rattle your brain, as i am sure it will work, thanks coRpSE for another great module. zwinkern
Sat Sep 19, 2020 7:45 pm
Original Poster
Clan Leader
Top Dog
2614 Posts
coRpSE
Currently Offline
Offline

Most Played:
This week: 46.0hrs.
Total Played: 237hrs.
  
Don't get much, huh?
— zardos wrote
Hi coRpSE, well did a complete install of E then F and re-installed it again, but still the same thing, but dont  let it bother you m8 i will setup a proper website on the net, by the way i have been using wamp64, as i say dont let it rattle your brain, as i am sure it will work, thanks coRpSE for another great module. zwinkern


Okay, it is probably WAMP. I had used Wamp 64 for a while, but when I was trying to figure out why it wasn't allowing the fopen to work, I swaped out to the 32 bit since that is what was causing the issue a few years ago. After trying it, I just gave up and coded it on my live server.

Side note. I did re-upload a new copy of the system that now subdues the errors from displaying and some minor changes here and there.


 
Mon Sep 21, 2020 4:09 pm
Original Poster
Clan Leader
Top Dog
2614 Posts
coRpSE
Currently Offline
Offline

Most Played:
This week: 46.0hrs.
Total Played: 237hrs.
  
Don't get much, huh?
Okay, I figured out the issue zardos. It's something with WAMP and how it handles cURL's.
To fix this, all you need to do is add in one line into a file.

Open: public_html/includes/functions_evo_custom.php

Find:

Code: [ Select all ]

curl_setopt( $ch, CURLOPT_RETURNTRANSFER, true );



ADD AFTER : On a new line:

Code: [ Select all ]

curl_setopt( $ch, CURLOPT_SSL_VERIFYPEER, false );



NOTE:
Only do this if you're on a localhost. I guess WAMP and other localhost are configured by default to support CA certificates, so by default, it'll reject all SSL certificates as unverifiable.

This is taken from curl's "Details on Server SSL Certificates":
If the remote server uses a self-signed certificate, if you don't install a CA cert bundle, if the server uses a certificate signed by a CA that isn't included in the bundle you use or if the remote host is an impostor impersonating your favorite site, and you want to transfer files from this server, do one of the following:

1) Tell libcurl to not verify the peer. With libcurl you disable this with curl_easy_setopt(curl, CURLOPT_SSL_VERIFYPEER, FALSE); With the curl command line tool, you disable this with -k/--insecure.

2) Get a CA certificate that can verify the remote server and use the proper option to point out this CA cert for verification when connecting. For libcurl hackers: curl_easy_setopt(curl, CURLOPT_CAPATH, capath); With the curl command line tool: --cacert


coRpSE


 
Tue Sep 22, 2020 3:39 pm
NOOB!!!
36 Posts
^7[^2I^7S^1S^...
Online
Most Played:
This week: 44.6hrs.
Total Played: 879hrs.
  
Don't get much, huh?
Ok coRpSE thanks for that info m8, i will set it up again and give it a try and let you known, thanks again  zwinkern


 
Wed Sep 23, 2020 12:43 pm
Original Poster
Clan Leader
Top Dog
2614 Posts
coRpSE
Currently Offline
Offline

Most Played:
This week: 46.0hrs.
Total Played: 237hrs.
  
Don't get much, huh?
Updated my first post with an update that is in the works for it.


 
Fri Sep 25, 2020 3:28 pm
Original Poster
Clan Leader
Top Dog
2614 Posts
coRpSE
Currently Offline
Offline

Most Played:
This week: 46.0hrs.
Total Played: 237hrs.
  
Don't get much, huh?
n/p, glad it helped.

There are a few other small projects that I am working on to help improve the CMS. I know Lonestar is also busy working on a few things. I am hoping by the end of this year, we can have a update that will bring new features since the last update was more of a "Back End" patch with some front side changes, but not many "features".


 
Sun Sep 27, 2020 1:06 pm
Nuke Dev / Coder
63 Posts
Lonestar
Currently Offline
Offline
  
Doesn't like playing games!
coRpSE, did you write this last post?


 
Sun Sep 27, 2020 1:11 pm
Original Poster
Clan Leader
Top Dog
2614 Posts
coRpSE
Currently Offline
Offline

Most Played:
This week: 46.0hrs.
Total Played: 237hrs.
  
Don't get much, huh?
Why yes I did, I had to manually change it in the database


 
Goto page Previous  1, 2
Forums ©