Nuke Sentinel !P2Country not displaying correct location?

2

Fri Nov 02, 2018 3:19 pm
Clan Leader
Top Dog
2600 Posts
Well, over the past year, I have received a few PM's and talked to a few people on TS3/Discord/Steam about this and I want to clarify something up about the IP2Country displaying wrong information. The database of IP's that is used is from
Please login to see this link
Get registered or Log in
and there are bound to be discrepancies from what you may get from arin or some other geoIP site. This is what software77 says about the discrepancies:

We use the registry assignments provided by the registrars. However discrepancies creep in especially in cases of large multinational companies who have their base of operation on one country and satellite offices in other countries. Typically what happens is that a company based in say, the United States, also has a branch in Africa or Asia.

In many cases, when the company is assigned a new block of IP addresses these will reflect the correct country (Africa or Asia for example). However, sometimes the location of the parent company is used - USA for example. This leads to an anomaly, where looking up the IP you know to be in one country appears to be somewhere else.

This is especially true of companies like AOL, Verizon, Sprint, Telefonica and others who do not operate only in one country. We have found IPs for both AOL and Verizon for example which are outside the US but show as originating in the US which is obviously not correct.

Although this only represents a tiny fraction of a percent, this is something that should be kept in mind.


Even showing them that, people still didn't understand why there IP was showing them in a different country, so I developed a script that is a one off on our site called WhoIS Lookup, which you can see in the left "Main Menu" block. That system will check multiple "whois" systems and display the information of what those site have. Well, today, I did a search for a certain IP and it reminded me of the many conversations I had on this subject and Figured it was a good example of what is going on.

For privacy reasons, I am not going to display IP's or the information for this IP, but it came down to this one IP range showing 2 different countries.

  • In block 1, it was displaying that the IP was coming from GB and the block was owned by Virgin Media.
  • In range 2, it was displaying that the IP was coming from NL and didn't show who owned it, those were left blank.


Both whois information were both originated from ripe.

In the end, no matter where we get our ip2country tables, there will always be discrepancies. If you are someone that is seeing this happening to you, yes, we could use another DB, (Database), but, then someone else may be effected. Unfortunately, there is no "Perfect" system out there that will display the right information for every IP out there. It would be nice if everyone could get on the same page, but they aren't.

For scripts like the Honeypot and what not, it's fine, but, for other blocks and modules on the site, something I have been thinking about doing on my site is building in the system to just display the flag you assign to it and if you don't assign a flag, then it will use the automated system.
Sat Nov 10, 2018 5:35 am
Clan Leader
Top Dog
2600 Posts
Anyone that have been running into this issue where its been showing you in the wrong country, can you contact me in a PM. I currently have done a change for the next release of the CMS and would like anyone that been seeing this issue, contact me and I will send you the changes to test out for me.

Thanks.


 
Forums ©